How-To Articles Suggest an article

Search the Knowledgebase
Importing PST Files to Outlook

Importing all PST Folders and Emails into M365 Outlook

  1. Open Outlook
  2. To see your storage utilization, go to the File -> Info Menu in Outlook and look for this.  Most PST files are under 2GB and should easily be migrated to M365 Outlook.
  3. Close all PSTs to be imported from the Outlook client (e.g., right-click on your .pst in your folder list and choose Close Outlook Data File)
  4. Exit Outlook to assure the PST files are free from any connections to the client.
  5. Relaunch Outlook
  6. Decide PST import location.
    • New Folder:  Create a new folder if you actively use the PST folders and emails
    • Archive Folder:  Use the existing Archive folder if you are importing folders and emails from a PST file that you rarely access.
    • Note: For Microsoft 365, Exchange, Exchange Online, and Outlook.com accounts, your Archive folder already exists, even if you've never used the feature before. You'll find it in your Outlook folder list. If you don't see the folder and you're using Outlook 2016 or Outlook for Microsoft 365, go to File > Office Account > Update Options > Update Now.
  7. Click on/Select the folder you would like to import your PST into.
  8. Go to the File -> Open & Export Menu and Select Import/Export
    Open 'Import/Export'
  9. Select “Import from another program or file” and click Next.
    Import
  10. Select “Outlook Data File (.pst)” and click Next.
    Select Outlook Data File (.pst)
  11. Browse to your .pst file, select it, and click Open.
    Select old file
  12. Choose whether you want to allow, replace, or not allow duplicate items. Then click Next.
  13. Import into the current folder (The one you just created or the ARCHIVE folder)
    Import into the current folder
    • If you want to import the entire .pst file, select the main folder containing all subfolders. Then select the checkbox labeled “Include subfolders” OR if you only want to choose certain folders, expand the Outlook Data File until you see a specific folder you want to import. Select that folder.  Then select the checkbox labeled “Include subfolders”
  14. The emails and folders will appear in your currently selected folder. If you need to make any final adjustments, simply drag and drop the emails and folders to the correct location.

 

Alternative:  Manually Move Folders from PST file to Outlook

This option lets the user manually open an Outlook Data File (.pst) and choose which folders to import. This can be a better option when the user wants to import only specific folders and subfolders within the .pst file.

  1. If your .pst is not already opened in Outlook, choose File | Open & Export
  2. Choose Open Outlook Data File
  3. Find your .pst file (either C: or H: drive), select it and click Open.
  4. In your Office 365 folder list, right click on your email address (or account name) and choose New Folder
  5. Name the folder (e.g., pst folder contents)
  6. Next, in the folder list, locate your .pst file and click the arrow to expand the list of folders.
  7. Select a folder and drag it to the new folder you just created under your Office 365 mailbox.
  8. Repeat for each folder you need to move.
  9. When finished, right click on the .pst folder and choose Close "foldername"

When should I use Archive and Online Archive?

We recommend that you use the Archive feature to keep your Inbox clear of messages that you’ve already answered or acted on. Think of the Archive like a file folder. You can store items in the Archive folder and still access them easily. You can also delete messages or move them to specific folders, if that’s more your style.

For users who have large mailboxes in a Office 365 Enterprise organization, we recommend that administrators set an Archive Policy that moves items to an Online Archive after one year or less if users are reaching their mailbox quota faster. This ensures users don’t have to delete old mail to make room for new mail. Mail that is older than the specified time can be moved from both the Inbox folder and the local Archive folder.